Degraded performance on Nebius

Incident Report for Lightning AI

Resolved

This incident has been resolved.
Posted May 15, 2026 - 13:02 UTC

Investigating

Nebius workloads are currently experiencing degraded performance on the platform.
Posted May 14, 2026 - 19:08 UTC