Degraded performance on Nebius

Incident Report for Lightning AI

Resolved

This incident has been resolved.
Posted May 21, 2026 - 01:12 UTC

Investigating

Nebius workloads are currently experiencing degraded performance on the platform.
Posted May 20, 2026 - 21:15 UTC